XP Pro SP2 Fatal Error @ startup

Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

phatmattrat

Thread Starter
Joined
Dec 9, 2003
Messages
178
Today I was de-fragmenting my hard drive, as I haven't done so in ages. I had to interrupt it at about 56% however so my mom could use the computer. After restarting, Windows refuses to boot giving this lengthy error:

STOP - c000021a {Fatal System Error}
The Session Manager Initialization system process terminated unexpectedly with a status of 0xc000003a (0x00000000 0x00000000)
The system has been shut down.


I'm guessing that interrupting the de-fragmentation while moving a system file might have prompted this. Is this anyway I can fix this without having to re-format? I'm currently using my 4GB HD with my "just-in-case-this-crap-happens" installation of XP... so its obviously not a hardware issue (other than the main hard drive at least). I'm thinking the Recovery Console might fix it... not sure. Theres a lot of stuff on that hard drive that I cannot back up and it would be painful to lose. Thanks :)
 

phatmattrat

Thread Starter
Joined
Dec 9, 2003
Messages
178
An update to this problem. I was able to read the error that usually flashed by so fast before the error I posted previously. For some reason it stayed on longer than usual and it was like this:

"autochk program not found"

I tried running chkdsk with the recovery console, it said it found one or more errors but it didn't say it did anything about it. Any ideas?
 
Joined
Dec 9, 2000
Messages
45,855
I gather you are completely locked out of Windows?

Are you getting the STOP - c000021a {Fatal System Error}

when trying to boot in Safe Mode as well?

And have you ever tried Last Known Good Configuration?

Having run chkdsk from the Recovery Console, I'm not sure what else you could do there.

The "hits" for this error are few and don't seem to apply:

http://www.google.com/search?hl=en&...ESS_TERMINATED+site:microsoft.com&btnG=Search

http://www.jsifaq.com/SUBB/tip0900/rh0907.htm

It's remotely possible that if there is a corrupt system hive at fault here, you might get back in by following the procedure to recover from a corrupted registry:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;307545
 

phatmattrat

Thread Starter
Joined
Dec 9, 2003
Messages
178
Thats right... I can't get into Safe Mode either... same result. I actually tried that right off the bat. I have not tried Last Known Good Config, but I'll give it a shot. Just ran chkdsk /r, it took about 2 hours and said it found and fixed one or more errors... however upon re-boot same thing.

I'll try Last Known Good Config, then the last link you gave there and let you know. Looks like I'm going to end up losing a lot of data though :(
 

phatmattrat

Thread Starter
Joined
Dec 9, 2003
Messages
178
Update:

Tried Last Known Good Config, no go. Bit the bullet and re-formatted... lost about 30GB of very important data. Thanks Microsoft. Re-installing drivers, browsers, and applications... will probably be up all night. Better get some Cola.

Thanks for trying to help, but as usual Windows did me in again. :rolleyes:
 
Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top