1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

XP setup gets stuck.

Discussion in 'Windows XP' started by Xandrios, Feb 14, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. Xandrios

    Xandrios Thread Starter

    Joined:
    Feb 14, 2008
    Messages:
    1
    Right then i'll dive straight into the problem:

    I did a large-scale upgrade, and so I had to do a repair install of XP Home. The setup runs perfectly until the very end, during the 'Saving Settings' part with 2 minutes remaining, where it just seems to stop.
    It doesn't crash, the information and little green dots keep cycling, and it happens in exactly the same place every time, so I'm fairly sure its not due to faulty hardware.
    After some research, I found that the problem could be due to the SP2 disk I made using an older version of nLite, but the problem continues using a new disk made with the most recent version.

    I've tried Microsoft's advice here: http://support.microsoft.com/kb/811267, but to no avail.

    The only thing I can find is the last entry into the setuperr.log:

    Error:
    Setup could not register the OLE Control C:\WINDOWS\system32\macromed\flash\flash.ocx because of the following error:
    DllRegisterServer returned error 2147647516 (8002801c).

    I have tried deleting this folder, but there is one file, Flash9.ocx, that will not delete. Running the setup with every other file deleted does not help, although it does add flash.ocx to that folder.
    I have installed another copy of XP onto a different partition to allow me to get at the setup logs etc, but in the above folder for this XP install, there is only flash.ocx, no Flash9.ocx (I presume Flash9 is a later version).

    I have pretty much run out of ideas, apart from getting rid of Flash9.ocx, but it says Access Denied, so I don't know how to.

    This problem is driving me mad, so I do hope someone here will be able to help me.:confused:
     
  2. ARC Hellraiser

    ARC Hellraiser

    Joined:
    Aug 28, 2008
    Messages:
    4
    Hi all I have the identical error BUT mine is at set up after a repair was done.

    setup encountered an error while tring to set security
    Error:
    Setup could not register the OLE Control C:\WINDOWS\system32\macromed\flash\flash.ocx because of the following error:
    DllRegisterServer returned error 2147647516 (8002801c).


    the 1st error window shows missing "asms" file
    enter path to load and gives the following string
    \GlobalRoot\device\cdrom\i386

    my XP CD is in drive I: so i put I:\i386 and it just sits there:confused:
    I:\i386\GlobalRoot\device\cdrom\i386

    when i hit cancel i get the log which says the above in red

    Please help...


    Ed -----> Hellraiser

     
  3. ARC Hellraiser

    ARC Hellraiser

    Joined:
    Aug 28, 2008
    Messages:
    4
    After hours of reading all i can find is:

    The 0x8002801c error usually means that you don't have permission register the file

    but they do not tell you how to fix XP if windows will not load after a
    repair..!!!:(:(:mad::mad:

    Can anybody guide me thru this..??
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/683141