YouTube/Google keeps changing preferred Language Settings

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Vaietzi

Thread Starter
Joined
Jul 6, 2018
Messages
1
Hi all,
YouTube (and Google) keeps changing my language settings to the local one after every ~10th watched video, even though my preferred one would be English. I did:

1. a browser reinstall (didn't help)
2. a complete system reinstall with the same browser (didn't help)
3. switched to a different browser (didn't help)

Fun fact: I use two computers - a desktop and a laptop. On the laptop my browser not only retains the language settings, but for some weird reason YT's old layout as well (without any special browser extension). To make sure later I copied all of its settings to my desktop's (exact same) browser but YT still kept on living its own life. Both PC's run the same OS and have the same language settings as well.

The people and Google's tech minions wouldn't help us at the Google Product Forum site even though there's tons and tons of posts about the automatic language switching issue.
Your help is greatly appreciated.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top