Zero Audio Input

ColdLasagna.TTV

Thread Starter
Joined
May 25, 2020
Messages
3
Ok, I have literally tried everything. Headset is a Steel Series Arctis 7 Pre 2019 Edition, it is USB, microphone worked as of two days ago, turned off the headset, put my PC to sleep, woke up to zero audio input from any source. Also I purchased a Corsair HS35 headset 4 hours after my other headset wouldn't work, it is a wired headset with microphone, windows does not pick up the microphone either. They show up in device manager and I can see them, and they both play audio through the headset just fine, but neither microphone works in windows 10.

Prior to waking up after the microphone working just fine, I didn't install anything new and windows only updated a "definition update" for defender. I consider myself pretty good with PC's and troubleshooting them but this has me pulling my hair out.

Here is the list of what I have tried:
Uninstalled/Reinstalled/Updated audio drivers (native and steel series)(multiple times)
Device manager activate deactivate etc.
Privacy settings are correct.
It is my default device.
Ran windows (useless) troubleshooter multiple times.
Works on other windows 10 PC's, tested it. Both headsets work, with microphones.
Took apart said Steel Series to make sure there were no hardware issues with the board.
Looked to see if my mobo somehow randomly disabled an audio input, doesn't have that option.
Installed 3rd party audio drivers.
Tried two pairs of random ear bud headsets with microphones, nada.
And finally Reset Windows to fresh, put all my files on storage SSDs, 2 hours ago. Nothing is any different.

I am out of ideas. I have spent hours searching for hope. Maybe it's a hardware issue? But I feel that's unlikely since the audio output still works and the wireless headset is USB.

Maybe if I cry on it, it will feel bad for me and fix itself?

Hardware: i7 6700k, ASROCK Z170 MOBO, 32gb DDR4 Ram, On-board sound, Nvidia GTX 1070, Steel Series Arctis 7 Pre 2019 Edition.
 
Joined
Jan 10, 2020
Messages
372
Have you tried plugging the headset into a different USB port?
It sounds like you may have a faulty USB port.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top